Was man bei Wubi nicht tun sollte

Nachdem ich ja einen Desktop und einen Server auf Ubuntu laufen habe, läuft auf meinem Netbook (Samsung NC10) Windows XP. Oder sagen wir besser: „lief“.

Da ich auf die Möglichkeiten eines komfortablen Linux nicht verzichten wollte, habe ich mit Wubi ein Ubuntu installiert, welches ich gestern auf Lucid aktualisiert habe. Dummerweise habe ich dabei einen kleinen Fehler gemacht und in der Auswahl einer Partition für GRUB2 meine Rootpartition ausgewählt, in der Annahme, es sei die Root-Partition des Virtuellen Filesystems.

Nun habe ich ein Netbook, das extrem schnell bootet. In die „grub rescue>“-Shell.

Heute abend werde ich mal gucken, was sich da mit einem Boot-USB-Stick retten lässt. Leider ist der Bootsektor nämlich so unbrauchbar, dass ich nichtmal die Rescue-Funktion booten kann. Vielleicht ist das dann doch der Anstoß, das System auf Linux umzustellen. Wir werden es sehen.

Updates, Updates, Updates (2)

Mehrere Sachen stoßen mir nach dem Update auf 8.10 weiterhin auf. Seit der Installation hatte ich in den Videos einen Blaustich, Abhilfe schaffte vorübergehend der Befehl:

Nebeneffekt: im (komischerweise zeitgleich zu totem-gstreamer installierten) totem-xine waren die Farben (ursprünglich richtig) verdreht, während totem-gstreamer das ganze richtig angezeigt hat.

Was mich daran verwundert ist die gleichzeitige Installation von beiden Backends, in Feisty, Gutsy und Hardy waren die Backends nur unter Deinstallation des jeweils anderen installierbar, das Update von Hary auf Intrepid hat beide Backends gleichzeitig installiert.

Meine Lösung

Deinstallation von totem-gstreamer, entfernen des hue-Parameters und installation des neuesten NVidia-Treibers mit EnvyNG. Und schon funktioniert alles wie gehabt. Selbst das Problem mit dem verschwindenden Mauszeiger trat (zumindest in den letzten 15 Minuten unter reproduzierten Bedingungen des vorherigen Verschwindens nicht wieder auf.

Nach dem Update ist vor dem Update

***

Kleiner Hinweis vorweg: Wer momentan nicht den FF3b5 nehmen möchte (Designer, Leute mit vielen Plugins etc…), sondern den FF2 und das, ohne sein Profil zu zerhauen, der mache foldendes im Terminal, bevor er den Firefox zum ersten Mal in Hardy startet:

user@host:~$ sudo rm /usr/bin/firefox
user@host:~$ sudo ln -s /usr/lib/firefox/firefox-2 /usr/bin/firefox

Damit wird der Firefox 2 über den Symlink „firefox“ aufgerufen. Das ganze setzt natürlich einen installierten Firefox 2 voraus.

***

Okay. Hardy läuft. Mittlerweile auch einigermaßen stabil. Was mir dabei so aufgefallen ist:

  • Das Benutzeralbum (aka „Gnome face browser“) fehlt
  • Grafikfehler bei den transparenten Panels (kurz nach dem Einloggen)
  • Komische Symbolgrößen in den Panels. Bei einer Panelbreite bzw. -höhe von 25 Pixeln ist z.B. das Mülleimer-Icon zu groß
  • Das Numpad funktioniert nicht so wirklich zuverlässig. Es steuert meinen Mauszeiger.
  • Amarok und gleichzeitig Warsow laufen lassen geht nicht – soundmäßig. Das zuletzt gestartete Programm hat keinen Sound.
  • Tastenkombos sind teilweise nicht mehr da (Compiz)
  • Das CSSM-Profil ist bei den Desktop-Einstellungen nicht mehr auswählbar, was bei temporärer Arbeit ohne Compiz zu blöden Wursteleien mit der Konfiguration desselben führt.

Für das eine oder andere Problem habe ich auch Lösungen parat:

  • sudo add-shell /bin/bash“ behebt das Problem (bei mir nur temporär)
  • Panels auf 24 Pixel stellen um das kleinere Symbol zu bekommen
  • Für das Numpad unter System » Einstellungen » Tastatur den Reiter „Maustasten“ auswählen und den Haken entfernen. Kann man auch gleich in dem Eingabefeld unten sehen, dass es funktioniert.
  • Den Soundbug mit Amarok und beispielsweise Warsow:
    • Amarok bekommt in den Einstellungen xine als Engine und alsa als Modul
    • Im Warsow-Skript fügt man die Zeile „export SDL_AUDIODRIVER=alsa“ ein. Ich habe das in Zeile 10 gemacht
  • Im Tool CSSM die Tasten-Einstellungen neu setzen

Im großen und ganzen ist das alles nichts, was ein „normales“ Produktivsystem behindert, aber für ein LTS meines Erachtens auf jeden Fall ziemlich übel. Und Firefox 3 Beta 5 sollte sich demächst auch erledigt haben.

Hardy Heron – Ubuntu 8.04

Okay, ich geb’s ja zu, das System ist schon einen Moment länger draußen. Und zwei geupdatete Geräte mit 8.04 und ein mit Wubi installiertes Firmennotebook habe ich auch unter meinen Fittichen und problemlos hinter mich gebracht.

Das Acer Extensa von meiner Schwester kann jetzt 3D-Desktop und Open-GL-Transitions von OpenOffice.org, mein kleines Medion/MSI auch, aber extrem langsam. Da müsste ich mal nach dem ATI-Treiber gucken, ob sich da nicht was in Bezug auf Compositing und 3D-Beschleunigung machen lässt. Allerdings ist das eher unwichtig, das System läuft stabil und WLAN geht auch.

Die erwarteten Features für den neuen Kernel 2.6.24 sollten eigentlich eine Unterstützung der Broadcom-Treiber enthalten, der, so hatten wir gehofft, dem WLAN-Modul im Acer endlich Leben einhauchen sollte. Das hat dann doch nicht geklappt, ist aber ja keine Verschlechterung gegenüber vor dem Update. Aber mit einem selbstkompilierten NdisWrapper wollte ich es dann demnächst mal probieren, ich hab da ein sehr plausibles und gut erklärtes HowTo gefunden, die Zeit es durchzumachen allerdings noch nicht.

Trotz guter Erfahrungen fehlt da noch ein Rechner. Mein „home“. Gegenüber den zwei Notebooks habe ich hier einige Fremdquellen und angepasste Sachen drauf, von daher könnte ein Update hier etwas kritischer werden. Da dieser Rechner in den letzten zwei Wochen allerdings unverzichtbar war, auch nicht für 3 Stunden und da ich hier ein komplettes Partitionsbackup fahren möchte, bevor ich update, war das bisher nicht möglich.

Die Entscheidung, den Firefox 3 beta 5 als Standardbrowser einzusetzen halte ich nach wie vor für eine absolute Fehlentscheidung, insbesondere bei einem als Enterprise-System gedachten LTS-Release. Mein Firefox-Profil werde ich unter diesen Umständen wohl nochmal extra sichern müssen. Der Rest des Updates sah allerdings sehr gut aus, auch unter Performance-Gesichtspunkten.

WordPress 2.5 » Meine Meinung

So, seit etwa einer Stunde läuft hier jetzt WordPress 2.5. Zuerst einmal ist mir aufgefallen, dass mein geliebtes „Flexible Upload“-Plugin nicht mehr seinen DIenst tut, der neuen, schicken Oberfläche erstes Opfer. Vielleicht werde ich mal das bisher viel gelobte Fluency Theme mal ausprobieren.

Tags

Die Tagverwaltung funktioniert, aber ich hatte mir mehr davon erhofft. Mehr im Sinne von Konsolidierungsfeatures, eine richtige Übersicht über alle Tags vielleicht und nicht so eine 10seitige Liste von einzelnen Wörtern. Vielleicht ist das aber auch mein Problem und außer mir benutzt niemand anderes über 100 Tags. Wenigstens gibt es eine Tagempfehlung unter dem Beitrag.

Bilder/Upload

Was den neuen Bildupload angeht, den werde ich demnächst mal angemessen untersuchen, auf den ersten Blick schauts ganz gut aus, auch wenn ich das alte Upload-Form besser fand, weil es einfacher und vor allem parallel zum Schreiben bedienbar war. « Allerdings geht es trotzdem parallel, wenn man die Dateilinks mit dem Mausrad andrückt, um ein neues Tab damit zu füllen »

Der Rest

Es wird sich zeigen, wie die neue Oberfläche in Zukunft funktioniert, die fehlenden Entwurfslinks im neuen Artikel vermisse ich momentan, und der Speed ist auch nicht so pralle wie behauptet.

Bei Problemen halte ich es wie alle anderen: Sollte euch was auffallen, was hier garantiert nicht richtig ist, bitte ab in die Kommentare damit. Danke.

Und bitte benutzt ECHTE eMail-Adressen. Ihr werdet von mir nicht vollgespammt und ich gebe keine eMail-Adressen weiter. Alles safe hier. Aber ich möchte keine „nospam@irgendwo.xyz“ oder „peter@ist.lustig“ oder ähnliches mehr sehen. Danke.